Set and Map additions in the latest draft

Andrea Giammarchi andrea.giammarchi at
Mon Oct 29 19:01:00 PDT 2012

cool, I have asked 'cause only FF was exposing it and at some point I
thought it was removed.

On Mon, Oct 29, 2012 at 6:47 PM, Brendan Eich <brendan at> wrote:

> Not sure what you mean -- size is "in" as a getter (non-enumerable, I
> trust).

nobody, but I believe first String.prototype hack will be to put a "points"
getter ( or "size", why not ) in order to retrieve the length in points
rather than chars. size() is quite common, hence the question.

> Andrea Giammarchi wrote:
>> Moreover, will be size, for common naming convention purpose, be used
>> also for string pointValues so that length will be the current misleading
>> one but size will be the right amount of points per string ?
> Who ever said size would be provided for strings? Or that it is an apt
> name?
> /be
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the es-discuss mailing list