Re: Avoiding overloading the term “prototype”

Russell Leggett russell.leggett at gmail.com
Mon Oct 22 13:51:40 PDT 2012


>
> By the way, let deprecate (that is, recommend not to use) __proto__ and
> introduce @parent (or other term) instead, while both having the same
> behaviour.
>
>
I'm not sure what to call it, but I think this would be much nicer than
__proto__ and consistent with the new way of doing things. Here are some
ideas:

   - @proto
   - @extends
   - @parent
   - @prototype
   - @prototypeOf

@prototypeOf seems a little silly as a property name, but it would work
well with getPrototypeOf()

- Russ
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20121022/68d9b5a6/attachment.html>


More information about the es-discuss mailing list