Re: Avoiding overloading the term “prototype”

Axel Rauschmayer axel at rauschma.de
Mon Oct 22 13:36:37 PDT 2012


> I was just too scared to bring it on, because it seemed that this is set in stone.

The risk is that renaming increases the confusion instead of fixing it. And I had forgotten that we already have Object.getPrototypeOf(), but that should largely be replaced by __proto__ in the future.

But I think it’s worth it to at least try to improve things. At the moment, it is difficult to talk about, without confusing people.

-- 
Dr. Axel Rauschmayer
axel at rauschma.de

home: rauschma.de
twitter: twitter.com/rauschma
blog: 2ality.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20121022/5b89dfab/attachment-0001.html>


More information about the es-discuss mailing list