should we rename the Program grammar production?
rossberg at google.com
Thu Oct 11 08:54:43 PDT 2012
On 11 October 2012 17:49, John J Barton <johnjbarton at johnjbarton.com> wrote:
> "Script" is not neutral but neither is "Program" plus it's just wrong.
> The language needs a name for both the unit of compilation and the
> assembly of those units. The latter is a program right? So the former
> needs a different name.
> "CompilationUnit" is a bit long but more correct.
Except that the "unit of compilation" is an individual function in
most contemporary JS implementations. ;) More generally, I think that
implementation-specific notions like "compilation" are to be avoided
in a language spec.
Script sounds perfectly reasonable to me.
More information about the es-discuss