should we rename the Program grammar production?
John J Barton
johnjbarton at johnjbarton.com
Thu Oct 11 08:49:54 PDT 2012
On Wed, Oct 10, 2012 at 4:20 PM, Rick Waldron <waldron.rick at gmail.com> wrote:
> Allen Wirfs-Brock wrote:
> I proposed that we replace "Program" in this context with "Script". This
> is much less confusing and matches the most common manifestation of an ES
> Program as an HTML script block.
> +1 -- it the term at least some engines use, and it makes more sense for
> eval, or at least it matches everyday usage.
> "Script" might be the most common execution context, but there is more then
> one of those to consider. I think "Program" is just the right amount of
> neutral. Also "script" has a negative connotations, eg "script kiddies" etc.
(I apologize for hitting Send on my phone with an errant finger
resulting in an empty post).
"Script" is not neutral but neither is "Program" plus it's just wrong.
The language needs a name for both the unit of compilation and the
assembly of those units. The latter is a program right? So the former
needs a different name.
"CompilationUnit" is a bit long but more correct.
More information about the es-discuss