Symbols, Protocols, Frames, and Versioning
brendan at mozilla.org
Thu Oct 4 16:59:11 PDT 2012
Allen Wirfs-Brock wrote:
> On Oct 4, 2012, at 4:02 PM, Brendan Eich wrote:
>> Dave had a suggestion for an alternative name to Symbol.intern, it's so obvious in hindsight:
>> public @iterator = Symbol.from('iterator');
>> No jargon, perhaps at the price of connoting singleton symbol, but still.
> actually sounds to m a bit closer to the right concept.
Nice, I buy it. Connotation of intern'ing or memoization, compared to
"from" which suggests conversion.
Kevin should weigh in, since he is thread-starter.
More information about the es-discuss