Kevin Smith khs4473 at
Wed Nov 14 08:41:52 PST 2012

>  Why go purposefully against the existing terminology of the JavaScript
> ecosystem? Just say “deferred” where you have “promise” and “promise” where
> you have “future” and you avoid needless confusion and conflict.

I prefer to find the optimal solution first and then consider migration
costs later.  I think migration costs are in general overstated in these
matters (I made that mistake a couple of years ago with modules).

Plus, "Deferred", seriously?  It's not even a noun.   : )

- Kevin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the es-discuss mailing list