Array.prototype.contains

Rick Waldron waldron.rick at gmail.com
Fri Nov 2 10:25:12 PDT 2012


On Fri, Nov 2, 2012 at 1:20 PM, Erik Arvidsson <erik.arvidsson at gmail.com>wrote:

> On Fri, Nov 2, 2012 at 12:30 PM, Mark S. Miller <erights at google.com>
> wrote:
> > I also support calling it "has" as Rick suggests. Perhaps this also helps
> > suggest that it is like the other "has"s, which use SameValue, and not
> like
> > indexOf.
> >
> > (I am still sad we did not fix indexOf, lastIndexOf, and switch when we
> > arguably had the chance.)
>
> If we call it "has", should we also rename String.prototype.contains?
>

Blitzed! I was just drafting a reply asking the same thing.

I think for consistency, yes... Although I'm not sure about using SameValue


Rick




> --
> erik
> _______________________________________________
> es-discuss mailing list
> es-discuss at mozilla.org
> https://mail.mozilla.org/listinfo/es-discuss
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20121102/4cf0dee5/attachment.html>


More information about the es-discuss mailing list