Array.prototype.contains

Erik Arvidsson erik.arvidsson at gmail.com
Fri Nov 2 10:20:50 PDT 2012


On Fri, Nov 2, 2012 at 12:30 PM, Mark S. Miller <erights at google.com> wrote:
> I also support calling it "has" as Rick suggests. Perhaps this also helps
> suggest that it is like the other "has"s, which use SameValue, and not like
> indexOf.
>
> (I am still sad we did not fix indexOf, lastIndexOf, and switch when we
> arguably had the chance.)

If we call it "has", should we also rename String.prototype.contains?

-- 
erik


More information about the es-discuss mailing list