arrows and a proposed softCall

Brendan Eich brendan at mozilla.com
Mon Jun 4 15:47:39 PDT 2012


Yehuda Katz wrote:
> I don't know whether it makes sense for a brand-new API to be designed 
> this way, but for APIs that presently make (possibly misguided) use of 
> `this` in place of a first parameter, the new (user-initiated, not 
> available in ES3) binding behavior provides a single shot at a better 
> way forward.

Yeah, this is a variation on Mark's use-case and I think a 
Function.prototype.isBound (or better name) should be considered.

/be


More information about the es-discuss mailing list