A different semantics for WeakMap#get default value

Kris Kowal kris.kowal at cixar.com
Mon Jan 16 16:46:20 PST 2012

On Mon, Jan 16, 2012 at 4:39 PM, Andrea Giammarchi
<andrea.giammarchi at gmail.com> wrote:
> then the method should be called "getOrSetIfNotThere(obj, def)" 'cause get()
> would mislead too much

I’ve been calling this method "getset" for about three years, hoping
it would catch on :P


Kris Kowal

More information about the es-discuss mailing list