Re: ECMA-262, 9.5: Why the name “posInt”?

Allen Wirfs-Brock allen at wirfs-brock.com
Sat Feb 18 11:11:14 PST 2012


Just a bad name choice.  You should file a bug at bugs.ecmascript.org

Allen

On Feb 18, 2012, at 6:27 AM, Axel Rauschmayer wrote:

> Quote: “Let posInt be sign(number) * floor(abs(number)).”
> 
> Why is this variable called “posInt”? It can’t be an abbreviation for “positive integer”, because it can be negative(?)
> 
> -- 
> Dr. Axel Rauschmayer
> axel at rauschma.de
> 
> home: rauschma.de
> twitter: twitter.com/rauschma
> blog: 2ality.com
> 
> _______________________________________________
> es-discuss mailing list
> es-discuss at mozilla.org
> https://mail.mozilla.org/listinfo/es-discuss
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20120218/11968d1b/attachment.html>


More information about the es-discuss mailing list