Renaming [[GetOwnProperty]]

Kang-Hao (Kenny) Lu kennyluck at csail.mit.edu
Fri Feb 3 06:18:19 PST 2012


(Sending on behalf* of Franky <qjy1111 at hotmail.com>)

Dear everyone who diligently worked on ECMAScript Edition5,

I am often confused by the name of the internal method
[[GetOwnProperty]](p). This name, if read literally, would indicate that
this method gets a property, but in fact this method returns a property
descriptor instead. Therefore, I am wondering if it should be renamed
[[GetOwnPropertyDescriptor]] or [[GetOwnPropretyDesc]]?

Thank you for spending your precious time in reading this letter.

Franky. 2012-02-01

* His mail was likely rejected twice either because the encoding
handling of his email agent is crappy or he hasn't subscribed to this list.


More information about the es-discuss mailing list