i18n API - resolvedOptions

Marcos Caceres ecmascript at marcosc.com
Fri Aug 31 05:31:54 PDT 2012

This is a bit of bike shedding.... Currently, the spec defines "resolvedOptions" - which is using a noun for a function name. Generally speaking, nouns should not be used as function names, only for attributes/getters. 

I would urge the function be renamed to "resolveOptions()". Dropping the "d" makes it a verb and gives the operation a sense of active-voice immediacy. I think that more accurately reflects what the method call does (it resolves the options on call and returns you an object) VS returning a set of options that were resolved in the past. 

Kind regards,

Marcos Caceres

More information about the es-discuss mailing list