waldron.rick at gmail.com
Sun Aug 26 17:56:54 PDT 2012
On Sunday, August 26, 2012 at 7:30 PM, Brendan Eich wrote:
> Rick Waldron wrote:
> > > But Array.of is not. Maybe Array.new is a good name.
> > Array.of is unambiguous with the current ES specification
> Array.new is ok too, though -- no problem with a reserved identifier as
> a property name. It's darn nice for Rubyists.
> OTOH Array.of matches the preposition pattern used in Array.from. But I
> don't think this trumps Array.new.
Nor do I, but I think it poses a problem for polyfilling (which is not a silver bullet).
+1 Array.new, but I still think Array.of sounds, feels and looks nicer
> Cc'ing Dave for his thoughts.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the es-discuss