Internationalization API: Requiring Unicode 5.0

Norbert Lindenberg ecmascript at norbertlindenberg.com
Sun Apr 29 21:15:15 PDT 2012


The latest published draft of the ECMAScript Internationalization API requires Unicode 4.1 as the minimum supported Unicode version. This was intended to reflect the version supported in Windows Vista, the oldest operating system on which we assumed anybody might want to implement this API while relying on OS services.

In the meantime I found out that Vista actually supports Unicode 5.0. I'm therefore changing to Unicode 5.0 as the minimum supported version.

If you have concerns about this change in the internationalization API, please speak up.

Regards,
Norbert


More information about the es-discuss mailing list