Direct proxies update

Sam Tobin-Hochstadt samth at
Thu Nov 24 07:04:34 PST 2011

On Thu, Nov 24, 2011 at 9:45 AM, David Bruant <bruant.d at> wrote:
> - Definition of a standard "@reflect"
> module: <>
> One observation I made while working on this module is that it's probably a
> bad idea to use keywords as trap names (delete, new), since such names
> cannot be straightforwardly imported/exported from modules.
> How so?

You can't do the following:

import {new, delete} from "@reflect";

because you can't bind `new' and `delete'.  Even if this were allowed,
then `new(...)' would still be a syntax error.

> We should probably consider using the names 'deleteProperty' and 'construct'
> instead.
> If that's really the case, I would prefer changing identifiers that can be
> imported/exported from modules rather than changing names of the Reflect
> API.

It's really not about modules -- these names are reserved, and can't
be made into bindings.
sam th
samth at

More information about the es-discuss mailing list