Alternative syntax for <|

Russell Leggett russell.leggett at gmail.com
Wed Nov 16 08:19:52 PST 2011


On Wed, Nov 16, 2011 at 11:07 AM, Jake Verbaten <raynos2 at gmail.com> wrote:

> It's simply that
>
> var x = someProto beget { ... }
>
> reads nicer then
>
> var x = someProto extends { ... }
>
> I'd prefer to have readability on the non class related operator then the
> class related operator
>

I was actually suggesting extends on the left - so

    var x = extends someProto { ... }

Which reads better than someProto extends { ... }, because that reads as
though {...} is the parent.

- Russ
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20111116/36b32d93/attachment.html>


More information about the es-discuss mailing list