Classes: suggestions for improvement

felix felix8a at gmail.com
Tue Jun 14 13:05:55 PDT 2011


How about using "prototype" or "proto" as the keyword instead of "class"?

It's a declaration of a prototypical object used to generate other objects.

"prototype" is already a familiar word to JS programmers; this is just
extending its use into a new but similar context.

"prototype" has a looser, more script-y feel than "class".

"prototype" has less baggage than "class"; JS is likely to be the only
prototypal-inheritance language that most programmers know.

"proto Point { }" reads well in English, it's a proto-Point.


More information about the es-discuss mailing list