Proxy.isProxy (Was: using Private name objects for declarative property definition.)
brendan at mozilla.com
Wed Jul 13 09:28:28 PDT 2011
On Jul 13, 2011, at 1:23 AM, Tom Van Cutsem wrote:
> Perhaps Proxy.isProxy was used merely as an example,
That's right, it was one of several in seeking for naming conventions, and deeper distinctions among type-testing predicates. Not to worry -- I agree we should remove it.
> but wasn't the consensus that Proxy.isProxy is not needed? Dave pointed out that it breaks transparent virtualization. Also, there is Object.isExtensible which always returns |true| for (trapping) proxies. That means we already have "half" of Proxy.isProxy without exposing proxies: if !Object.isExtensible(obj), obj is guaranteed not to be a proxy.
> 2011/7/9 Brendan Eich <brendan at mozilla.com>
> Also the Proxy.isTrapping, which in recent threads has been proposed to be renamed to Proxy.isProxy or Object.isProxy.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the es-discuss