Pure win: Array.from and Array.of

David Herman dherman at mozilla.com
Sun Jul 10 13:33:03 PDT 2011


I mentioned two benefits I can see to Array.of over []-literals here:

    https://twitter.com/#!/littlecalculist/status/89854372405723136

1) With Array.of you know you aren't going to accidentally create holes, and

2) if you're passing it to a higher-order function you know you aren't going to trip over the single-uint32-arg special case.

That said, the "readability" story you and I tweeted about is not so compelling given that, in the first-order usage pattern an array-literal is strictly more readable. So a longer name like Array.fromElements or something might be okay.

Dave

On Jul 10, 2011, at 10:33 AM, Rick Waldron wrote:

> _that_ is the compelling use-case I was looking for.
> 
> Rick
> 
> 
> 
> -- Sent from my Palm Pre
> 
> On Jul 10, 2011 1:23 PM, Brendan Eich <brendan at mozilla.com> wrote: 
> 
> On Jul 10, 2011, at 10:18 AM, Rick Waldron wrote:
> 
>> The more I think about it, I still can't come up with any really exciting use cases where Array.of would outshine anything that already exists. I say strike it from the wishlist.
> 
> Higher-order programming with Array as constructing-function bites back for the single-number-argument case. That's where Array.of helps.
> 
> /be
> 
> _______________________________________________
> es-discuss mailing list
> es-discuss at mozilla.org
> https://mail.mozilla.org/listinfo/es-discuss

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20110710/980c9972/attachment-0001.html>


More information about the es-discuss mailing list