Object.eq is ready for discussion

Ash Berlin ash_js at firemirror.com
Tue Sep 7 09:34:18 PDT 2010

On 7 Sep 2010, at 17:18, P T Withington wrote:
> On 2010-09-07, at 12:02, Brendan Eich wrote:
>> 3. identical
> If I had a vote, +1
> Is there someplace that concisely explains the cost of just fixing `===` so I could understand why that is not a choice?

FWIW this sort of naming issue is a rabbit hole that CommonJS fell down when it came to method names for a unit test framework[0]. There was no real consensus, but we settled on equal meaning == and strictEqual meaning ===. 


[0]: http://wiki.commonjs.org/wiki/Unit_Testing/1.0
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20100907/85ac713e/attachment.html>

More information about the es-discuss mailing list