Object.eq is ready for discussion

Maciej Stachowiak mjs at apple.com
Mon Sep 6 14:45:47 PDT 2010

On Sep 6, 2010, at 9:30 AM, Jeff Walden wrote:

> On 09/05/2010 08:31 PM, Maciej Stachowiak wrote:
>>> The strawman has a note where I suggested matching "hashcode" with "identity" as the method name. If nothing else, the name length and lack of hackerly abbreviation recommend it. Comments?
>> I would expect a function named "identity" to be a function of one argument that returns it unmodified, rather than a two-argument predicate that implements an equivalence relation. "eq" seems like an ok name. "egal" will probably seem more mysterious than "eq".
> Object.identical seems to imply the right things, certainly better than Object.identity.  To the extent I want to get involved in this paint job, I think this is the best shade I've considered.

Object.identical is a good name.

 - Maciej

More information about the es-discuss mailing list