We need to name "EphemeronTable" (was: Do we need an experimental extension naming convention?)

Ash Berlin ash_js at firemirror.com
Fri Jul 2 15:36:54 PDT 2010

On 2 Jul 2010, at 23:17, David Flanagan wrote:

> Mark S. Miller wrote:
> However, many objected to "ephemeron" as obscure
>>    jargon. We have not yet settled the name we are giving this abstraction.
> It is the language of GC implementors, and won't make sense to JS programmers.
>> I'll be happy with almost any name that everyone else can agree to that isn't technically incorrect, i.e., not "WeakKeyTable".
>> If we can't agree on anything else, I propose that we default to "EphemeronTable". It has the virtues of
>> * being technically correct
>> * giving credit where due
>> * unlikely to conflict with any other names in use by legacy JS code.
> How about EphemeralMap?
> Changing the obscure noun Ephemeron to an adjective reduces the jargon-level substantially, but retains the three virtues Mark lists.
> This name make even more sense to JS programmers if Harmony also introduced an ordinary Map class for mapping objects to values with regular strong references.  (I assume there is some way to build an ordinary Map on top of an ephemeron table.)
> 	David

Without meaning to tread on anyone's toes here, from my PoV as someone who doesn't work on any JS engine its the Ephemer{al,on} part that is confusing/obscure.

Is some variation based around "Weak" not possible?

More information about the es-discuss mailing list