brendan at mozilla.com
Wed Feb 3 16:26:29 PST 2010
On Feb 3, 2010, at 4:07 PM, David Herman wrote:
> I like it. I might prefer "module loader" for a bit more
> concreteness. But it has the benefit of concreteness and familiarity.
+1 on module loader, loader for short. Thanks, Mark!
> On Feb 3, 2010, at 4:03 PM, Mark Miller wrote:
>> On Wed, Feb 3, 2010 at 3:11 PM, David Herman <dherman at mozilla.com>
>> > Well, a "module system" is a language construct that provides
>> modules. I think "sandbox" sort of suggests more isolation than is
>> necessarily provided. PLT Scheme uses the worst possible name for
>> the concept (I won't even say what it is, it's so awful).
>> > I'll think about alternatives and update the wiki.
>> How about "module group"?
>> Since, AFAICT, the concept being named here, in Java, corresponds
>> to a ClassLoader, I suggest "loader". (E calls these "loaders" as
>> es-discuss mailing list
>> es-discuss at mozilla.org
>> Text by me above is hereby placed in the public domain
> es-discuss mailing list
> es-discuss at mozilla.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the es-discuss