"Pretty" function expression names
Mark Miller
erights at gmail.com
Mon May 4 11:18:56 PDT 2009
On Mon, May 4, 2009 at 11:12 AM, Michael <Michael at lanex.com> wrote:
> From what I understand arguments.callee is going away. If that is the case,
> then from within that function how would I call it?
>
> function "my description here" () {
> ...
> "my description here"(foo)
> };
>
> That doesn't seem right, but maybe I'm overlooking something.
Indeed. PT's original example was:
> var myFun = function "my description here" (...) { ... };
in which case you could call it as
myFun(foo)
(Note that this clarification should not be taken as an endorsement of
PT's proposal. I don't yet know what I think of it.)
--
Text by me above is hereby placed in the public domain
Cheers,
--MarkM
More information about the es-discuss
mailing list