Alternative to Function.bind

Brendan Eich brendan at
Fri Mar 27 17:23:09 PDT 2009

On Mar 27, 2009, at 11:42 AM, Igor Bukanov wrote:

> 2009/3/27 Brendan Eich <brendan at>:
>> although perhaps the name should be something else:
>> obj.bindSelfTo.method
>> or just
>> obj.bindTo.method
> IMO a better name would be boundedMethods or just bounded to emphasis
> that the result is a view that may work with any method like in:
> var obj2 = obj.bounded;

Mathemitcally speaking, a good word, but probably one of  
"obj.autoBind" or "obj.selfBound" is better.

You are right that this wants catch-alls, as do all the tiered  
virtualization sandbox schemes in the works and out there. We should  
get back to discussing catch-alls -- I have a draft saved somewhere...


More information about the Es-discuss mailing list