name property for built-in functions??
Allen.Wirfs-Brock at microsoft.com
Sat Feb 28 18:31:56 PST 2009
Because we have introduced a "name" property for function objects we have to specify what values the built-in functions in Section 15 each have for this property. Note that the value of this property is intended to be a descriptive name and is not necessarily a simple identifier. We have already taken advantage of this in specify the "name" of functions created using Function.prototype.bind.
So what should name property values be for a built-in function such as Array.prototype.printString? The straight forward thing to do is to say it is "printString". However, it would be potentially more useful for debugging purposes if it was "Array.prototype.printString".
Thoughts? I'm probably going to specify that simple identifier unless I hear a strong response in favor of using the fully qualified name.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Es-discuss