Should host objects be able to have [[Class]] "Function", "Array" etc.?
cam at mcc.id.au
Mon Nov 17 19:38:42 PST 2008
Hi Garrett and other list members.
> The better name would be something other than "filter" on a
> CSSStyleDeclaration. Maybe "svgFilter".
Yes, that’s a possible solution to the issue, especially since it’s not
particularly likely that many existing SVG documents use
CSSStyleDeclaration to look up the 'filter' property at the moment.
> > I don't think anybody is suggesting that these properties become part of the
> > standard. It seems to me that a conforming implementation should be able to
> > implement such compatibility hacks though, which is why they were brought
> > up.
> Internet Explorer 4 had css filters that predates the SVG filter
> (AFAIK). SVG filter creates a compatibility problem. Maciej says that
> they worked around this by having style.filter return undefined, but
> have that undefined be a special value that is == to "". I think it
> would be a good idea to raise the issue with the SVG WG. If the SVG WG
> wants to act in good faith, they should consider creating an
> alternative property name for browsers, style.svgFilter, for example.
I forwarded Maciej’s earlier mail to the SVG WG list for discussion:
and an issue has been raised:
Cameron McCormack ≝ http://mcc.id.au/
More information about the Es-discuss