Should host objects be able to have [[Class]] "Function", "Array" etc.?
dhtmlkitchen at gmail.com
Mon Nov 17 19:32:28 PST 2008
On Mon, Nov 17, 2008 at 12:17 PM, Blake Kaplan <mrbkap at gmail.com> wrote:
> On 11/15/2008 09:40 PM, Garrett Smith wrote:
>> Standardizing an MSIE property that works differently than in MSIE
>> creates compatibility problems on the web. A better alternative would
>> be to use a different property name.
> Who is supposed to use the better name here? Mozilla added undetectable
> document.all support to allow sites that didn't bother testing if the
> current browser was IE (e.g. via |if (document.all)| type tests) some chance
> of working. We obviously can't expose the same object under a different name
> as that would defeat the purpose. It isn't a 100% solution, but often these
> hacks won't be and don't need to be.
Yes, I understand this. It's not perfect, but it helps sites that rely
on document.all work. Same thing with marquee.
The better name would be something other than "filter" on a
CSSStyleDeclaration. Maybe "svgFilter".
> I don't think anybody is suggesting that these properties become part of the
> standard. It seems to me that a conforming implementation should be able to
> implement such compatibility hacks though, which is why they were brought
Internet Explorer 4 had css filters that predates the SVG filter
(AFAIK). SVG filter creates a compatibility problem. Maciej says that
they worked around this by having style.filter return undefined, but
have that undefined be a special value that is == to "". I think it
would be a good idea to raise the issue with the SVG WG. If the SVG WG
wants to act in good faith, they should consider creating an
alternative property name for browsers, style.svgFilter, for example.
> Blake Kaplan
More information about the Es-discuss