Kona [[Getter]] and [[Setter]] descriptions
petermichaux at gmail.com
Sun Nov 16 23:49:36 PST 2008
On Sun, Nov 16, 2008 at 11:36 PM, Brendan Eich <brendan at mozilla.com> wrote:
> On Nov 16, 2008, at 7:32 PM, David-Sarah Hopwood wrote:
>> The references to [[Get]] and [[ThrowablePut]] are needed because it is
> Anyone else find ThrowablePut misnamed?
I thought it was confusing.
> Total nit, but ThrowingPut would be
> better. Or FalliblePut, or to be long-winded, PutCapableOfThrowing but not
> ThrowablePut (the Put is not the object thrown, an exception is).
Any of these are better. ThrowingPut indicates what happens when
failure occurs and I think that is good if throwing is always what
happens when failure occurs. FailablePut doesn't make such indication.
More information about the Es-discuss