ES3.1 Object static methods rationale document

Brendan Eich brendan at
Wed Jul 16 14:27:26 PDT 2008

On Jul 16, 2008, at 1:41 PM, David Flanagan wrote:

> Brendan, I think you were correct when you originally wrote:
>> lookup : define :: get : put.
> I think that lookupProperty is much nicer than describeProperty, since
> "lookup" captures the getter nature of the method in a way that
> "describe" does not.

Connotations are many, ambiguity without a noun phrase (not just  
overloaded old "property") saying what's being "got" or "described"  
or "looked up" is inevitable. This means the stolid, safe name  
"getPropertyDescriptor" is least likely to confuse.

I see what you mean about describe in the context of setting a  
description (depict in a graphics context is problematic too) --  
thanks. Thesaurus doesn't include mental concept filtering, dammit.  
I'm sure we'll get this right, but I'm also pretty sure "getProperty"  
isn't the droid we are seeking.


More information about the Es4-discuss mailing list