ES3.1 Object static methods rationale document
brendan at mozilla.org
Wed Jul 16 12:40:22 PDT 2008
On Jul 16, 2008, at 12:31 PM, Allen Wirfs-Brock wrote:
> (I'm not going to get you to take the bait on "reify", am I?)
(no way! ;-)
> I think I like "describe" better than "inspect" for no particularly
> tangible reason, although it does have more characters. I generally
> find the Thesaurus a useful tool in this process and it turned up
> "depict" which is shorter but also seems to capture the same core
> distinction as "describe".
Length is less of an issue, given the rationale doc's points in favor
of "keyword parameters via object literals", etc.
> I think that the currently named getOwnProperty is more fundamental
> than getProperty so in considering length we should probably use
> the former as our benchmark. BTW, I'm open to arguments that we
> don't really need getProperty (as long as getPrototypeOf is kept).
> (Oh shit ... do we need to rename that one, too??)
No, that's a value-get, not a descriptor-get. But you raise a good
point: defineProperty creates an own property. Is there really a need
for getProperty as drafted? If not, I'd favor making describeProperty
return null if the named property is not "own", but in a prototype.
What are use-cases for getProperty as distinct from getOwnProperty?
> I think we've pretty much covered the "name space" and would be
> content, at this point, to sit back for a few days and see if
> anybody else is brave enough to argue for one name over another. If
> not I think we can reach agreement on one of these that we have
> been discussing.
Cool. I'm standing pat on describeProperty.
More information about the Es4-discuss