ES3.1 Object static methods rationale document

Ingvar von Schoultz ingvar-v-s at
Wed Jul 16 11:26:04 PDT 2008

Brendan Eich wrote:
> That was unclear, sorry. I meant to suggest that "lookupProperty" is  
> a shorter alternative to "getPropertyDescriptor". Using "lookup" or  
> "query" relieves the need for "Descriptor" at the end to disambiguate  
> value- from descriptor-getting. So:

I find inspectProperty() a little more descriptive and intuitive.

Ingvar von Schoultz

------- (My quirky use of capitals in code comes from my opinion that
reserved and predefined words should all start with lowercase, and
user-defined should all start with uppercase, because this will easily
and elegantly prevent a host of name-collision problems when things
like programming languages are upgraded with new labels.)

More information about the Es4-discuss mailing list