ES3.1 Object static methods rationale document
brendan at mozilla.org
Wed Jul 16 00:09:23 PDT 2008
On Jul 15, 2008, at 11:50 PM, Brendan Eich wrote:
> * getProperty and getProperties seem misnamed in light of common
> usage of "get", "[[Get]]", "getProperty", etc. all connoting value-
> getting, not descriptor-getting. getPropertyDescriptor is a bit
> long, but not fatally so. Worth renaming?
Shorter alternative verbs to "get": lookup, query. The analogy is
lookup : define :: get : put.
More information about the Es4-discuss