proper tail calls

Peter Michaux petermichaux at
Mon Jan 21 23:18:49 PST 2008

On Jan 21, 2008 10:50 PM, Brendan Eich <brendan at> wrote:
> On Jan 21, 2008, at 8:12 PM, Maciej Stachowiak wrote:

> > How about something like "tailcall" or "tailreturn".
> Or just "tail f(x, y)", Dave Herman's suggestion.

"tail" looks great and any of these three suggestions seem far better
than "goto".

(I'm still hoping this explicit version is optional.)


More information about the Es4-discuss mailing list