defineProperty/getProperty design sketch

Steven Mascaro subs at
Fri Apr 25 22:00:47 PDT 2008

> Instead, people were talking about a
> bunch of positional boolean flag parameters, which is a call-site
> readability disaster:
>     Object.defineProperty(obj, name, value, true, false, true)

Just pointing out that this would be self-documenting (with the same
performance) with named parameters:

Object.defineProperty(obj, name, value, writable: true, iterable:
false, deletable: true)

Which may be an option in future versions.

More information about the Es4-discuss mailing list