FxA test server for FXOS devs (Was: Re: dev server is fixed (idp.dev.lcip.org))

Jed Parsons jparsons at mozilla.com
Tue Nov 19 11:20:30 PST 2013


Wild guess - the server error ({"code":400,"error":"Bad Request","message":"First argument must be a number (400+) ...) is due to us hitting the wrong url; it's trying to throw a 404; but there's an internal error in the picl server that's not seeing the response code in the right place in some error handler.  Maybe?

So ... maybe this goes away once our urls are straightened out?

----- Mensaje original -----
> De: "Fernando Jiménez Moreno" <ferjmoreno at gmail.com>
> Para: "Shane Tomlinson" <stomlinson at mozilla.com>
> CC: dev-fxacct at mozilla.org
> Enviados: Martes, 19 de Noviembre 2013 6:10:34
> Asunto: Re: FxA test server for FXOS devs (Was: Re: dev server is fixed	(idp.dev.lcip.org))
> 
> 
> On 19/11/2013, at 12:50, Shane Tomlinson <stomlinson at mozilla.com> wrote:
> 
> > On 19/11/2013 04:29, Ryan Kelly wrote:
> >> 
> >> But if folks hate it, do speak up.
> >> 
> >> 
> >>   Cheers,
> >> 
> >>     Ryan
> > 
> > 
> > Thanks for making the URL updates Ryan. One thing that has been lost in the
> > last day is route matching for URLS that contain
> > `identity.mozilla.com/picl/`
> > 
> > The old URL to create an account was:
> > 
> > https://idp.dev.lcip.org/v1/identity.mozilla.com/picl/v1/raw_password/account/create
> > 
> > Fernando initially tried changing host name on device so the URL would be:
> > 
> > https://api-accounts.dev.lcip.org/identity.mozilla.com/picl/v1/raw_password/account/create
> > 
> > We were both seeing 404s when trying to create accounts.
> > 
> > Looking through the code, I could not find anywhere that referenced
> > `/identity.mozilla.com/picl` or any snippet that prepended anything other
> > than '/v1' to a route.
> > 
> > We found that we are able to create an account using:
> > 
> > https://api-accounts.dev.lcip.org/v1/raw_password/account/create
> > 
> 
> Actually, we are able to communicate with the server, but we are still not
> able to create accounts. We get:
> 
> "error":{"code":400,"error":"Bad Request","message":"First argument must be a
> number
> (400+)","info":"https://github.com/mozilla/fxa-auth-server/blob/master/docs/api.md#response-format","domainThrown":true,"errno":999,"log":[{"op":"RawPassword.accountCreate","rid":"1384870110471-16075-11201"}]}
> 
> Thanks for your help Shane!
> 
> Cheers,
> 
> / Fernando
> _______________________________________________
> Dev-fxacct mailing list
> Dev-fxacct at mozilla.org
> https://mail.mozilla.org/listinfo/dev-fxacct
> 



More information about the Dev-fxacct mailing list