<div dir="ltr"><div>Thanks Andrew :-)</div><div><br></div><div>I want to mention that on the AMO site, legacy addons now appear with a greyed-out "install" button.  This happens when even in Nightly with `extensions.legacy.enabled=true`.  The pref works and I can run legacy extensions, but the AMO site does not allow the user to install updates, including fixes for addons broken by removal of deprecated code.</div><div><br></div><div>"there is a preference that Nightly users can flip to re-enable loading of legacy extensions in the addons manager"</div><div><br></div><div>I don't seem to find anything in the addon manager to accomplish this, I had to take a guess at the name of the pref and flip it manually.</div><div><br></div><div>Kudos for another major step in the advancement into the next era!</div><div><br></div><div>Kevin<br></div><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Aug 10, 2017 at 10:00 AM, Andrew Swan <span dir="ltr"><<a href="mailto:aswan@mozilla.com" target="_blank">aswan@mozilla.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr"><div><br></div><div>After lots of recent discussion, it is finally happening.  The patch to flip the default setting to disallow legacy extensions is in autoland at the moment and, barring some snafu, should be in tomorrow's Nightly builds.  This is a bit anti-climactic since a few other changes that have already landed that broke a bunch of existing extensions.</div><div><br></div><div>Also this has been discussed in a few other threads but repeating here for folks that may have missed it: there is a preference that Nightly users can flip to re-enable loading of legacy extensions in the addons manager (of course this setting won't magically make extensions that rely on the sdk or any changed internal interfaces work).  We will continue to honor this preference in Nightly builds and in unbranded builds, but when 57 (and later versions) go to beta and eventually to release, that preference will be ignored.  If you're familiar with addon signing and the circumstances in which we allow it to be disabled, legacy extensions are handled in the same way.</div><div><br></div><div>If you notice any problems or have questions, you can contact me directly, use the dev-addons mailing list, or drop into #webextensions on IRC.</div><div><br></div><div>:highfive:s all around!<span class="gmail-HOEnZb"><font color="#888888"><br></font></span></div><span class="gmail-HOEnZb"><font color="#888888"><div><br></div><div>-Andrew</div><div><br></div></font></span></div>
<br>______________________________<wbr>_________________<br>
Dev-addons mailing list<br>
<a href="mailto:Dev-addons@mozilla.org">Dev-addons@mozilla.org</a><br>
<a href="https://mail.mozilla.org/listinfo/dev-addons" rel="noreferrer" target="_blank">https://mail.mozilla.org/<wbr>listinfo/dev-addons</a><br>
<br></blockquote></div><br></div></div>