Support for RequestUpdateCheckStatus

Mike Lissner mike at free.law
Wed Nov 29 19:29:25 UTC 2017


We have breaking API changes on our server that we want to roll out, and we
need all the people on old versions to upgrade, regardless of their choice
to disable updates. Is there a way to make it so that only the latest
version of the extension is supported?

I guess if not, this means we have to implement our own API for checking
the minimum supported API version, which is too bad since
RequestUpdateCheck would be perfect for this.

Mike

On Wed, Nov 29, 2017 at 9:56 AM Andrew Swan <aswan at mozilla.com> wrote:

>
> This was considered in bug 1314922 and resolved as WONTFIX.  You can read
> the reasoning in the bug comments.
> Also note that automatic extension updates are enabled by default, this is
> only an issue for users who have made an explicit choice to disable
> updates, and we honor the user's choice in this case.
>
> -Andrew
>
> --
Mike Lissner
Executive Director
Free Law Project
@freelawproject
https://free.law/donate/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/dev-addons/attachments/20171129/f9403ac0/attachment.html>


More information about the Dev-addons mailing list