Error in setting default search engine in mozilla using webextensions

Bob Silverberg bsilverberg at mozilla.com
Mon Nov 6 21:30:05 UTC 2017


To set a search engine as the default you need to specify the is_default
property on the search_provider in your manifest.json file, similar to the
following:

      "chrome_settings_overrides": {
        "search_provider": {
          "name": "DuckDuckGo",
          "search_url": "https://example.com/?q={searchTerms}",
          "is_default": true,
        },
      }

If you have any trouble with this, please let us know exactly what the
problem is, and please provide a copy of the code from your extension's
manifest.json file.

Bob


On Mon, Nov 6, 2017 at 2:17 AM, Santhosh Raam <sandeey.13 at gmail.com> wrote:

> Hi,
>
> I have developed search extension using webextension api. Everything is
> working fine, like downloading extension and change search engine. But
> problem is not accepting as default search engine. After downloading , it
> should configured as default search engine. I don't have any idea how to do
> that. Will wait for reply.
>
> Thanks,
> Santhosh Ramanujam
>
> _______________________________________________
> Dev-addons mailing list
> Dev-addons at mozilla.org
> https://mail.mozilla.org/listinfo/dev-addons
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/dev-addons/attachments/20171106/0ea1180c/attachment-0001.html>


More information about the Dev-addons mailing list